magic lantern

magic lantern

Downgrade Canon 7D firmware from 2.0.5 to 2.0.3 and install Magic Lantern

1w ago
SOURCE  

Description

I had to downdate/grade my Canon EOS 7D firmware from 2.0.5 to 2.0.3 to make Magic Lantern work. In this video i let you see as much as posible of the proces i went trough. The files i used can be downloaded here: https://www.dropbox.com/s/nzjb8urysv47uza/EOS-7D-firmware-and-autostart-ML.zip